DPM2007 Tape Libary Errors

I recently had a customer that had some problems with a HP 1/8 G2 Autoloader LTO 5 Drive.

We discovered some hardware problems and got the LTO 5 Drive replaced under warranty but they also began to run into some more problems with tape backup failures.

I had a support case with Microsoft and discovered a few things to help people in the future if they run into similar problems.

The easiest thing to do is to upgrade DPM2007 to 2010 which 9 times out of 10 will fix the problem and DPM 2012 will be with us soon! However its still always nice to fix tape problems when they occur and listed below are a few ways to help.

1.Open up the DPM Database which is normally servername\MS$DPM2007$
Then browse to a table tbl_MM_Drive and right click on it and click open then ensure that all items in the OperationOccuring field are set to 0 and the click save all.

2.Add a dword value “RSMCompatMode” in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent with a decimal value of 27. As per Microsoft KB978901

All tape inventories were failing for me prior to adding this DWORD to the registry.

3.Run DPMLibraryTest.exe to validate mounting and moving of tapes.

4. Run dpmbackup -db to create a backup of your DPM DB which you will need to do if you are upgrading to 2010.

5. One of the weaknesses of DPM is the inability to back up Oracle DB’s and Vmware. i365 have a plugin for DPM which can backup oracle & vmware. Yipee! You can read up on it HERE

6. Finally , Erasing tapes in DPM can sometimes take forever , so it would be nice to speed up that process and heres hows.

If your tape drive supports short erase, you can enable it on the DPM server by creating the DWORD UseShortErase under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent.

Set the value of the DWORD to 00000000.

After this value is set, all erase operations on the DPM server will be short erases. To revert to long erases, remove this registry key

Citrix XenApp Clients

I recently tried to download the latest XenApp 6 client. When I go to downloads , I see offline plugin and online plugin.

WHERE HAS THE ICA CLIENT GONE!!!

It was so easy to use and I thought by installing both offline plugin and online plugin I would get access to an ICA Client but it only shows Citrix Online Plugin in start menu/all programs. So I had a look in C:\program files\citrix\ica client and clicked on the application exe’s. Still no ICA Client.

So I did a bit of looking around on the web and i am not the only one confused.

There is a good article HERE on BrianMadden.com about the different Citrix Clients.

So I eventually found what I was looking for , I needed the Citrix Quick Launch Application which you can download HERE But even when you download it , it is not straight forward as you need to register TABCTL32.OCX They dont make it easy!!

All I wanted to do is test logins and roaming profiles.

If you dont want to go through all this hassle you could always just download mRemote which will let you connect to just about anything.

Xp32x Fax Clients connecting to Server 2008R2 Fax Server

When I think of electronic faxing I always think of Microsoft Small Business Server’s built in faxing or Zeta Fax or GFI.

Zeta Fax & GFI Faxmaker work really well and integrate really well into Exchange but can cost a bit as user counts increase.So I had to setup Server2008R2 Fax Server recently which is FREE and heres how I did it.

1.Install the Fax Server Role.
2.Ensure Firewall Rules are correct.
3.Share Fax Printer out to relevant security group or domain\users
4.Add x86 driver to fax printer. Download driver HERE
5.Change the Fax Service “LOGON AS” from NETWORK SERVICE to LOCAL SYSTEM also tick “interact with desktop”

Now here is the bit that got me! When I logged on as an administrator xp x86 client I could connect to the fax server via the the fax console without any problems.But it kept saying connection errors when connecting with a standard user.So i tried adding permissions to the fax printer but that was not correct.

6.Open up Fax Service Manager, Right Click on Fax , Properties, Security add in relevant users , security group.

Hyper-v failed to open attachment C:\clusterstorage\volume

I recently installed a 2 node Hyper-V cluster soon to be a 3 node and all was working really well until I added a DPM 2010 Agent.When I was trying to do a live migration it would move 100% but fail to start. So if I shutdown the vm and move to another host and try and start it. It still wont start!!!!! 😦

It was also affecting SCVMM , I could not push templates to my cluster.

I was starting to panic at this stage and was thinking I needed to rebuild my cluster, but the fix was really simple and required a few steps.

1) Start Registry Editor.
2) Visit the following registry key: ā€œHKLM\SYSTEM\CurrentControlSet\Services\FsDependsā€
3) Under the ā€œFsDependsā€ key, change REG_DWORD value ā€œStartā€ from ā€œ3ā€ to ā€œ0ā€
4) Restart the computer

Another culprit was SOPHOS, I excluded cluster.exe , c:\clusterstorage and it still would fail. So I also excluded the volumes C:\Clusterstorage\volume1 , C:\Clusterstorage\volume2 etc.. and it all worked fine.

Also to remove any ISO images attached to any VM , Like exchange 2010SP1 iso, after the iso has been removed , go into cluster manager , right click on the virtual machine, click on more actions and refresh virtual machine configuration.

My live migration is working perfectly again.

Office 365 Single Sign on through Active Directory Federation Sharing


With Office 365 , Users will be able to use their Windows Active Directory accounts to sign in to their Microsoft Online Services like Exchange online, SharePoint Online and Lync Online.

I am currently testing this sign on method and I much prefer it to the BPOS SSO Tool.

I am not a fan of the current BPOS SSO method as it is not seemless where as Office 365 method is.

Hyper-V Broken VHD – AVHD Chain

I first posted about broken vhd – avhd chains in December 2009, And since then I have helped many people throughout the world in recovering their data and made some friends along the way.

I have recovered data for people in france, germany , uk, australia, usa, brazil

A guy called Dave Loughner from Innovative Solutions in New York pointed out a great utility for recovering data from avhd & vhds.

It is Disk Digger and only cost $14.99, Best money you will ever spend if your really stuck. Dave tried about 30 recovery products before coming across Disk Digger.

As of writing this http://www.diskdigger.org is down but you can download it here

Also a point to note. The disk digger solution is absolutely the last resort as nothing is as good as merging all avhds and having a healthy server at the end.Using disk digger will get you back up to 50% of your data but not all.